iOS Development

flutter – Failled to run the app within the iOS emulator

Spread the love


problem :

[!] CocoaPods couldn't discover suitable variations for pod "libphonenumber_plugin":
  In Podfile:
    libphonenumber_plugin (from `.symlinks/plugins/libphonenumber_plugin/ios`)

Specs satisfying the `libphonenumber_plugin (from `.symlinks/plugins/libphonenumber_plugin/ios`)` dependency have been discovered, however they required a better minimal deployment goal.

Did not run Pod set up.

I wished to run app in iOS emulator.

This error have been raised when I’m tring to construct the app in iOS EMulator.

pubspec.yaml:



  identify: coincrux
  description: A  Flutter venture fro Astute Applied sciences

publish_to: 'none' 


model: 1.0.0+1

setting:
  sdk: '>=2.19.4 <3.0.0'

dependencies:
  cached_network_image: ^3.2.3
  candlesticks: ^2.1.0
  carousel_slider: ^4.2.1
  cloud_firestore: ^4.13.1
  cupertino_icons: ^1.0.2
  curved_navigation_bar: ^1.0.3
  firebase_auth: ^4.6.3
  firebase_core: ^2.20.0
  firebase_messaging: ^14.7.10
  firebase_storage: ^11.5.1
  flutter:
    sdk: flutter
  flutter_card_swiper: ^6.0.0
  flutter_launcher_icons: ^0.13.1
  get: ^4.6.5
  google_sign_in: ^6.1.4
  http: ^1.1.2
  image_picker: ^1.0.0
  intl_phone_number_input: ^0.7.3+1
  photo_view: ^0.14.0
  pin_code_fields: ^8.0.1
  supplier: ^6.0.5
  share_plus: ^7.0.1
  shared_preferences: ^2.2.1
  timeago: ^3.5.0

dev_dependencies:
  flutter_test:
    sdk: flutter
flutter_icons:
  android: "launcher_icon"
  ios: true

  image_path: "property/photographs/splashicon.png"
  
  flutter_lints: ^2.0.0

flutter:

  
  uses-material-design: true

  property:
    - property/photographs/
  
  fonts:
    - household: RobotoFlex
      fonts:
        - asset: property/fonts/RobotoFlex.ttf

Podfile

# Uncomment this line to outline a worldwide platform to your venture
platform :ios, '11.0'

# CocoaPods analytics sends community stats synchronously affecting flutter construct latency.
ENV['COCOAPODS_DISABLE_STATS'] = 'true'

venture 'Runner', {
  'Debug' => :debug,
  'Profile' => :launch,
  'Launch' => :launch,
}

def flutter_root
  generated_xcode_build_settings_path = File.expand_path(File.be part of('..', 'Flutter', 'Generated.xcconfig'), __FILE__)
  except File.exist?(generated_xcode_build_settings_path)
    increase "#{generated_xcode_build_settings_path} should exist. Should you're operating pod set up manually, make sure that flutter pub get is executed first"
  finish

  File.foreach(generated_xcode_build_settings_path) do |line|
    matches = line.match(/FLUTTER_ROOT=(.*)/)
    return matches[1].strip if matches
  finish
  increase "FLUTTER_ROOT not present in #{generated_xcode_build_settings_path}. Attempt deleting Generated.xcconfig, then run flutter pub get"
finish

require File.expand_path(File.be part of('packages', 'flutter_tools', 'bin', 'podhelper'), flutter_root)

flutter_ios_podfile_setup

goal 'Runner' do
  use_frameworks!
  use_modular_headers!

  flutter_install_all_ios_pods File.dirname(File.realpath(__FILE__))
  #goal 'RunnerTests' do
   # inherit! :search_paths
  #finish
finish

post_install do |installer|
  installer.pods_project.targets.every do |goal|
    flutter_additional_ios_build_settings(goal)
  finish
finish

Leave a Reply

Your email address will not be published. Required fields are marked *